Please describe the problem.

git-annex cannot build with GHC 8.2.1

What steps will reproduce the problem?

cabal install --jobs=8 --max-backjumps=100000 --only-dependencies --flags=s3\ webapp

What version of git-annex are you using? On what operating system?

Tested with 6.20170520 and HEAD at a983877279d5157d4e7a8c2397d9e541e3c41fa6

Please provide any additional information below.

Discovered during https://github.com/Homebrew/homebrew-core/pull/15934

==> cabal install --jobs=8 --max-backjumps=100000 --only-dependencies --flags=s3 webapp
clang: warning: -Wl,-headerpad_max_install_names: 'linker' input unused
clang: warning: argument unused during compilation: '-L/usr/local/opt/gettext/lib'
clang: warning: argument unused during compilation: '-L/usr/local/opt/libffi/lib'
clang: warning: argument unused during compilation: '-L/usr/local/opt/readline/lib'
clang: warning: argument unused during compilation: '-L/usr/local/opt/sqlite/lib'
clang: warning: argument unused during compilation: '-L/usr/local/opt/openssl/lib'
clang: warning: argument unused during compilation: '-L/usr/local/opt/icu4c/lib'
clang: warning: argument unused during compilation: '-L/usr/local/lib'
clang: warning: argument unused during compilation: '-L/System/Library/Frameworks/OpenGL.framework/Versions/Current/Libraries'
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: git-annex-6.20170520 (user goal)
trying: base-4.10.0.0/installed-4.1... (dependency of git-annex-6.20170520)
next goal: sandi (dependency of git-annex-6.20170520)
rejecting: sandi-0.4.0 (conflict: base==4.10.0.0/installed-4.1..., sandi =>
base>=4.7 && <4.10)
rejecting: sandi-0.3.6, sandi-0.3.5 (conflict:
base==4.10.0.0/installed-4.1..., sandi => base>=4.7 && <4.9)
rejecting: sandi-0.3.4 (conflict: base==4.10.0.0/installed-4.1..., sandi =>
base==4.8.*)
rejecting: sandi-0.3.3, sandi-0.3.2, sandi-0.3.1 (conflict:
base==4.10.0.0/installed-4.1..., sandi => base==4.7.*)
rejecting: sandi-0.3.0.1 (conflict: base==4.10.0.0/installed-4.1..., sandi =>
base==4.6.* || ==4.7.*)
rejecting: sandi-0.3.0 (conflict: base==4.10.0.0/installed-4.1..., sandi =>
base==4.7.*)
rejecting: sandi-0.2.3, sandi-0.2.2.1, sandi-0.2.2, sandi-0.2.1 (conflict:
base==4.10.0.0/installed-4.1..., sandi => base>=4.5 && <4.7)
rejecting: sandi-0.2, sandi-0.1.1, sandi-0.1 (conflict:
base==4.10.0.0/installed-4.1..., sandi => base==4.6.*)
Dependency tree exhaustively searched.

Have you had any luck using git-annex before? (Sometimes we get tired of reading bug reports all day and a lil' positive end note does wonders)

Yes :)

fixed --Joey