I'm running git-annex from https://aur.archlinux.org/packages/git-annex-bin btw on Archlinux.

I fetched a copy of my git-annex wedding test repo to a machine on ssh called 'bible'.

Now I'm trying to fetch via ssh from my local machine "X1C3".

I can't work out how to fetch from it from b1b15a9b-1aa1-4f94-8b9a-2186d71c0d1a .... what am I missing?

X1C3:~/annex/krwedding$ git-annex whereis krfeature.mp4
 whereis krfeature.mp4 (3 copies)
    00000000-0000-0000-0000-000000000001 -- web
    10418340-834d-41c2-b38f-7ee84bf6a23a -- s3
    b1b15a9b-1aa1-4f94-8b9a-2186d71c0d1a -- Jamie's bible
  web: http://r2d2.webconverger.org/2013-12-22/krfeature.mp4
  web: http://static.prazefarm.co.uk/krfeature.mp4
  web: https://objects.dreamhost.com/wedding-video/krfeature.mp4
X1C3:~/annex/krwedding$ git-annex get . --from "Jamie's bible"
git-annex: there is no available git remote named "Jamie's bible"
X1C3:~/annex/krwedding$ git-annex enableremote Jamie's bible
> ^C
X1C3:~/annex/krwedding$ git-annex enableremote "Jamie's bible"
git-annex: Unknown special remote name.
Known special remotes: s3
X1C3:~/annex/krwedding$ git-annex get . --from b1b15a9b-1aa1-4f94-8b9a-2186d71c0d1a
git-annex: there is no available git remote named "b1b15a9b-1aa1-4f94-8b9a-2186d71c0d1a"

Why doesn't the UUID work? :/

I even tried renaming the remote to the UUID... didn't work

Solution: Neither UUID or the description is used by get. I also should not have resorted to special remotes setup for setting up a git remote.

Issue 1

Keep getting git-annex-shell: user error (git ["config","--null","--list"] exited 126) even though when I run git config my return error is 0: http://ix.io/gJG

Solution: This was because my ssh git URL was incorrect. A better error message has been implemented: http://source.git-annex.branchable.com/?p=source.git;a=commitdiff;h=3439ea4

Issue 2

I can't work out the git-annex remote type for ssh, in order to rename the remote. I think the issue here is that my ssh remote name "Jamie's bible" doesn't match with the git remote name bible.

Solution: A rw git URL configured with git remote are not special remotes. I confused the two. If you need to define public git URL (time capsule use case), it is possible with an undocumented git annex initremote foo type=git location=url. So to summarise, just manually setup the git remote git remote add ssh://someplace/path/to/repo (don't worry about the name) and git-annex will find it!